Pear的PHP_Compat包

  Pear的PHP_Compat是個比較有趣的包,它提供了一些php4下也能使用的php5專有函數,比如file_put_contents,array_combine,str_split..........這樣即使是在php4的主機上,也能提前享受一點php5函數的便利.
  用法
  PLAIN TEXT
  PHP:
  <?php
  require_once'PHP/Compat.php';
  // load file_put_contents
  PHP_Compat::loadFunction('file_put_contents');
  // load str_split, array_chunk and file_get_contents
  PHP_Compat::loadFunction(array('str_split','array_chunk','file_get_contents'));
  ?>
  上面的例子說明,可以一次載入n個php5特有函數
  Package Information: PHP_Compat
http://pear.php.net/package/PHP_Compat
  作者:volcano發表于11月 23, 2006 at 7:42 am
  版權信息:可以任意轉載, 轉載時請務必以超鏈接形式標明文章原始出處和作者信息及此聲明
  永久鏈接 - http://www.ooso.net/index.php/archives/267