使用飞信体验版将波导D720心机自带的java程序删除

  一直听闻小 7 普版自带的 java 程序 / 游戏可以通过覆盖法删除,也尝试过,但却因为找不到合适的源 jar 文件而做罢。
   后来去客服刷成了心机,普机原有的两个收费游戏没有了,换成两个英文的 Demo 游戏和一个飞信。虽然不会再因为别人乱玩游戏而被扣掉话费,但是三个自带的 java 的使用率还是很低的,相当于摆设。飞信那玩意我一直不用,而两个 Demo 版的游戏太单调。
   起初也想通过覆盖法将自带的游戏删除。两个 Demo 游戏是找不到源 jar 文件了,不过飞信倒是很好找。于是上中国移动网上下载了飞信的源文件,版本为 1.0.17 , 与手机自带的版本相同。然后用手机进行安装,安装时提示已有相同版本,是否覆盖,选是,但是安装到一半的时候,问题出来了,提示“需要通过新版本进行安装授权”,然后用 jad 文件尝试引导安装,也是一样的结果。
   后来听说飞信出了 2.0 的版本,但是官方没 D720 的飞信 2.0 ,于是又下载了一个 SE K750C 的飞信 2.0 进行安装,可是却提示“不正确的 jar 文件 (jad) ”。又要做罢。
   昨天上网时在手游论坛看到一个飞信体验版,怀着试一试的想法,下载下来,安装时没显示已存在版本要覆盖的信息,直接安装成功。本以为已经失败了,就把他删除。可是却误打误撞的成功了。
   首先是,我发现 java 开始混乱了,我打开自己安装的 Op204 ,却进入了自带的 Demo 游戏。把 Op204 删除,发现自带的第一个游戏被删除了,而 Op204 却仍在,运行 Op204 ,发现进入的却是机子自带的第二个 Demo 游戏,于是接着把自己原来安装的 QQ 、 Anyview. 删除,结果 OP204 、 Anyview. 、 QQ 都在,而自带的三个软件都被删掉了,且剩下的 OP204 、 Anyview. 、 QQ 全都无法运行、删除。再安装其它任何一个,都没出现已有版本是否覆盖的提示,直接安装成功,而上面的三个无用的软件却还在,运行任何一个,都进入到刚刚安装的软件里。删掉的话,三个软件仍然无法运行、删除。
   然后安装一个节拍器,完成后,取消运行,再安装一遍,提示已有版本是否覆盖的时候选是,安装后,切到百宝箱里一看,哈哈,那三个无用的软件不见了,只剩下刚刚安装的节拍器,而且节拍器的选项里没有删除一项。
   再安装两个软件,一样的,选项里面没有删除项,再安装第三个,第三个可以删除了,也就是说:最上面三个软件被卡在那里,无法从选项删除。不过可以用覆盖法来删掉。
   我现在手机百宝箱卡的三个软件是:一个打砖块游戏( 63491 字节),一个俄罗斯方块游戏( 68398 字节),一个 Oprea Mini 204(176789 字节 ) , java 剩余空间为: 708608 字节。
   上面的方法有危险性,仅供参考交流,任何友人试用时对机子造成的影响本人不负责。
   鬼蓝
   2008-1-10